Documentation‎ > ‎

Installation

Requirements

In order to use Dimple with MATLAB, you need:
  • Java runtime environment (JRE - version 1.7 or later)
  • MATLAB (version 2013b or later) - Not necessary if you only want to use Dimple as a Java API.
If you would like to build Dimple from source you also need
  • Java development kit (JDK - version 1.7 or later)
  • gradle (version 2.10 or later)

Step by step instructions for using Dimple with MATLAB

  1. Download Dimple
  2. Unzip and put it in whatever directory you want.
  3. Start MATLAB
  4. In MATLAB, navigate to your new Dimple directory.
  5. Execute the startup.m script in the Dimple directory.
  6. Verify dimple has been installed properly by executing "testDimple".  This MATLAB function will run a suite of tests.  If you are missing some toolboxes (like the Communications or Statistics toolboxes) some tests will fail.
  7. Learn about Dimple.  Read the documentation in the doc directory and check out the code in the demos directory.

Using Dimple as a Java Library

If you want to use Dimple as a java API, you need to download dimple and include all of the jar files in solvers/lib.

Importing Dimple from JCenter Maven repository using gradle

Starting with version 0.06, Dimple is published as a project on Bintray and can be imported from the associated JCenter Maven repository. If you are using gradle to build your project, you will only need to add JCenter to your list of repositories and specify Dimple as a library dependency. For example:
    repositories {
       jcenter()
       // ... other repositories ...
    }

    dependencies {
       compile "com.analog.dimple:dimple:0.06"
       // ... other dependencies ...
    }
Comments